Posts by MrcS

    Hi,


    Another bug I've hit is regarding server passwords. Some characters aren't going correctly and thus results in password error.
    The character I've got problems with is "%" removing it from the password fixes the password error problem.


    Maybe just an unicode UTF-8 conversion problem?

    Error while trying to upgrade from 0.0.22 to 0.0.26: (as both versions are beta versions, I'll be upgrading manually anyways)


    Error in Browser is showed as: An exception occurred while executing 'SHOW FULL TABLES WHERE Table_type = 'BASE TABLE'': MySQL server has gone away


    Nginx logs this: 2017/12/09 13:37:09 [error] 6149#6149: *5 FastCGI sent in stderr: "PHP message: PHP Warning: Error while sending STMT_PREPARE packet. PID=6130 in /public_html/tsi/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/Mysqli/MysqliStatement.php on line 99" while reading response header from upstream, client: xx.xx.xx.xx, server: xxxx, request: "POST /tsi/index.php?controller=ajax&action=update HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "xxxx", referrer: "http://xxxx/tsi/index.php?controller=index&action=dashboard"


    Mysql logs: 2017-12-09T16:36:59.081118Z 297 [Note] Aborted connection 297 to db: 'admin_tsi' user: 'admin_tsiuser' host: 'localhost' (Got timeout reading communication packets)


    root# mysql admin_tsi -e "SHOW FULL TABLES WHERE Table_type = 'BASE TABLE'" <- query works fine
    +-------------------------+------------+
    | Tables_in_admin_tsi | Table_type |
    +-------------------------+------------+
    | tsi0_config | BASE TABLE |
    | tsi0_extensions | BASE TABLE |
    | tsi0_instance_perm_cats | BASE TABLE |
    | tsi0_instance_perms | BASE TABLE |
    | tsi0_instances | BASE TABLE |
    | tsi0_user_groups | BASE TABLE |
    | tsi0_users | BASE TABLE |
    +-------------------------+------------+


    The files were upgraded, I believe only the DB didn't.
    Well, it may not be a bug, maybe it's just my odd setup (php-fpm+nginx tried both socket and port php connections) without apache. Just felt like sharing :)

    Hi there, great software you're developing there. I'll try to give feedback as long as I have my license :D


    when the password is wrong, the ts3 bans the ip for a few seconds, it's NORMAL. But your software is not catching the exception:


    2017/12/08 02:15:47 [error] 11911#11911: *58 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught TeamSpeak3_Adapter_ServerQuery_Exception: connection failed, you are banned (you may retry in 531 seconds) in /public_html/tsi/vendor/planetteamspeak/ts3-php-framework/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php:319


    and this error generates an Error 500 - Server Error (can't troubleshoot clientside) and the system gets inaccessible for as long as the ban is there, as soon as it ends it gets normal again.